Sélectionner une page
Accueil 5 Articles 5 Additionner la même plage sur plusieurs feuilles dans Excel
Excel : savoir comment utiliser les formules 3D

Additionner la même plage sur plusieurs feuilles dans Excel

Par Planète Excel
le 17 février 2023

Saviez-vous qu'il est possible de travailler avec Excel en 3D ?

Bien sûr, il ne s'agit pas ici de transformer Excel en Autodesk, Blender et autre ZBrush... Nous parlons ici de formules et de références 3D.

Une référence qui fait référence à la même cellule ou plage de cellules sur plusieurs onglets différents est appelée référence 3D. Ce type de référence est super pratique  pour faire des opérations en utilisant les données de plusieurs feuilles de calcul qui suivent le même modèle.

Nous allons prendre un exemple simple avec la fonction SOMME. Nous disposons de données de ventes pour une liste de produits stockées dans un onglet différent chaque mois. La présentation des données adopte le même schéma dans chacun des onglets. Voici le tableau de janvier :

Excel : Addition plusieurs plages plusieurs feuilles - 1er onglet

Voici le tableau de février :

Excel : Addition plusieurs plages plusieurs feuilles - 2e onglet

Vous le voyez, tous les tableaux sont identiques, jusqu'au tableau Total qui doit nous permettre d'obtenir une vue consolidée sur l'année complète :

Excel : Addition plusieurs plages plusieurs feuilles - onglet Total

Comment obtenir cette consolidation facilement ?

Excel nous permet de résoudre ce problème de multiples façons. La manière la plus élégante et la plus rapide est certainement l'utilisation d'un tableau croisé dynamique. Mais tout le monde n'est pas familiarisé ou très à l'aise avec cette technique !

Aujourd'hui, je vous présente la manière la plus facile de répondre à cette problématique avec une formule.

Création de notre formule Excel en 3D

Rendez-vous l'onglet Total, et commencez à saisir la formule dans la cellule B2 : =SOMME(

Excel : Addition plusieurs plages plusieurs feuilles - début de la fonction SOMME

Ensuite, cliquez ensuite sur l'onglet Janv, maintenez la touche Shift enfoncée, cliquez sur l'onglet Déc, puis relâchez la touche Shift.

Vous voyez comment les douze feuilles de notre consolidation ont été sélectionnées et prises en compte dans notre formule ? Celle-ci est devenue  =SOMME('Janv:Déc'! :

Excel : Addition plusieurs plages plusieurs feuilles - Sélection des onglets

Nous y sommes presque ! Complétons la formule en indiquant la cellule à additionner. Il suffit de cliquer directement sur la cellule B2 :

Excel : Addition plusieurs plages plusieurs feuilles - Sélection de la cellule

Finalisons la formule, en fermant la parenthèse de la fonction SOMME. Validez en appuyant sur la touche Entrée, la somme des ventes pour le premier produit apparaît.

Il ne vous reste plus qu'à double-cliquer sur la poignée de recopie pour reporter la formule dans le reste du tableau !

Voici un récapitulatif en animation :

Excel : Addition plusieurs plages plusieurs feuilles - SOMME de la cellule B2

Faites de même avec la cellule C2, et votre tableau de consolidation sera complet...

Mais attention, ne recommencez pas la formule à 0 dans la cellule C2 : il suffit d'utiliser les poignées de recopie, et le tour est joué !

Sélectionnez les cellules B2:B12, cliquez sur la poignée de recopie, maintenez le bouton de la souris enfoncé et déportez-vous vers la droite pour englober la colonne C :

Excel : Addition plusieurs plages plusieurs feuilles - poignée de recopie

Conclusion

Votre consolidation est terminée en quelques clics de souris !

En faisant référence à la même cellule sur plusieurs onglets différents, vous pouvez simplement et rapidement réaliser des opérations de consolidation des données de plusieurs feuilles de calcul qui suivent le même modèle.

Planète Excel

Exploitez tout le potentiel d'Excel : cours gratuits, trucs et astuces pour maîtriser les feuilles de calculs.

Suivez-nous sur les réseaux sociaux :

Excel : buy me a coffee<br />
Vous aimez notre contenu ? Offrez-nous un café !
Calendrier 2024 à imprimer PDF et Excel

Calendrier 2024 à imprimer PDF et Excel

Retrouvez le calendrier de l'année 2024 et ses déclinaisons au semestre ou au mois. Il vous accompagnera dans vos suivis de projets, dans l'organisation de votre travail ou tout simplement pour établir votre planning personnel. Nos calendriers sont gratuits et libres...

lire plus
9 erreurs Excel et leur solution

9 erreurs Excel et leur solution

Lorsqu'on crée une formule dans Excel, il est courant d'être confronté à une erreur. Celle-ci apparaît sous la forme d'un message à la place du résultat de la formule. Passons en revue les 9 erreurs de formules les plus courantes ! 1. #DIV/0 Cette erreur apparaît...

lire plus
Travailler avec les dates dans Excel

Travailler avec les dates dans Excel

Pas toujours facile de travailler avec les dates dans Excel... Comment changer le format des dates et heures ?  Comment effectuer des calculs simples, comme la différence entre deux dates, connaître le nombre de jours ouvrés, trouver le premier jour ou le dernier jour...

lire plus
Fonction RECHERCHEX

Fonction RECHERCHEX

Vous travaillez sur un tableau de données Excel et vous avez besoin de trouver une valeur spécifique ? La fonction RECHERCHEX est idéale pour cela : elle vous permet de rechercher une valeur dans un tableau et de renvoyer la valeur correspondante. Elle fait...

lire plus
Format de nombres

Format de nombres

Changer de format de nombre, c'est par exemple indiquer le nombre de décimales après la virgule que l'on souhaite voire apparaître, c'est aussi l'utilisation d'un séparateur de milliers, ou d'un pourcentage, ou encore choisir le format des dates, etc... Il existe un...

lire plus

Présentation des tableaux croisés dynamiques

Vous avez certainement entendu ce terme un peu mystérieux pour les débutants sur Excel : les tableaux croisés dynamiques (ou TCD). Pour beaucoup, le TCD paraît trop abstrait, et nombreux sont ceux qui préfèrent utiliser des tris, des filtres, et des tableaux "maison"...

lire plus

Inscrivez-vous à la Newsletter Planète Excel ! 😊

 

Inscrivez-vous pour recevoir les dernières actualités et les meilleurs trucs et astuces de Planète Excel par email.

🎁

Recevez en cadeau la liste complète des fonctions Excel, au format xlsx et pdf !

 

Votre inscription a réussi ! Un mail vous est envoyé dans la minute pour vous permettre de télécharger la liste complète des fonctions Excel.