Sélectionner une page
Accueil 5 Articles 5 9 erreurs Excel et leur solution
9 erreurs Excel les plus courantes et leur solution

9 erreurs Excel et leur solution

Par Planète Excel
le 10 novembre 2023

Lorsqu'on crée une formule dans Excel, il est courant d'être confronté à une erreur. Celle-ci apparaît sous la forme d'un message à la place du résultat de la formule.

Passons en revue les 9 erreurs de formules les plus courantes !

1. #DIV/0

Cette erreur apparaît lorsque vous essayez d'effectuer une division par zéro, ce qui n'est pas possible mathématiquement.

Par exemple, =A1/A2 renvoie l'erreur #DIV/0 si la cellule A2 contient 0 ou si elle est vide.

Remplacez la valeur 0 ou vide par une valeur non nulle pour corriger cette erreur !

    2. #NOM?

    Cette erreur se produit lorsque le nom utilisé dans la formule n'est pas reconnu par Excel. Avez-vous bien orthographié la fonction que vous utilisez ? Si vous faite référence à une plage nommée, celle-ci est-elle bien connue et orthographiée ?

    Par exemple, =SOUSTOTAL(B5:B300) n'est pas une formule qui sera comprise par Excel, car la fonction s'orthographie SOUS.TOTAL.

    Vérifiez que le nom utilisé dans la formule est correct et qu'il correspond à une fonction définie ou à une plage de cellules nommée !

    3. #REF!

    Cette erreur apparaît lorsque la référence de cellule dans une formule est incorrecte, généralement à la suite d'une suppression de cellules.

    Par exemple, la formule =SOMME(B8:B12) reverra l'erreur #REF! si vous supprimez la colonne B. Remarquez que la formule est elle-même modifiée automatiquement par Excel : elle devient =SOMME(#REF!).

    Remplacez la mention #REF! présente dans la formule par une référence correcte à une cellule ou une plage de cellule.

    4. #VALEUR!

    Cette erreur se produit lorsque le type de donnée ne correspond à ce qui est attendu dans une formule.

    C'est souvent le cas lorsque on souhaite réaliser une opération mathématique, mais qu'une ou plusieurs valeurs ne sont pas numériques. Par exemple, vous additionnez deux cellules dont l'une contient du texte :

    Excel : erreur valeur

    Notez que si vous utilisez la fonction SOMME, l'erreur ne se produit pas : en effet, cette fonction trie automatiquement les valeurs en fontion de leur type, et additionne les valeurs numériques uniquement.

    5. #NOMBRE!

    Cette erreur survient lorsque les valeurs numériques utilisées dans une formule ne sont pas valides.

    Par exemple, la formule =RACINE(-5) reverra l'erreur car la racine carrée d'un nombre négatif n'existe pas.

    On peut également rencontrer cette erreur en présence d'un nombre saisi ou d'un résultat si grand qu'il dépasse les capacités d'Excel.
    En effet, Excel est exposé à des limites de calculs qu'il faut veiller à respecter, notamment :

    Plus grand chiffre positif autorisé

    9,99999999999999E+307

    Plus grand chiffre négatif autorisé

    -9,99999999999999E+307

    Plus grand nombre positif autorisé via formule

    1,7976931348623158e+308

    Plus grand nombre négatif autorisé via formule

    -1,7976931348623158e+308

    6. #NUL!

    Cette erreur se produit lorsqu’il manque un séparateur (: ou 😉 entre 2 références de cellules.

    Par exemple, on a saisi la fonction SOMME en oubliant les deux point dans la référence d'une plage : =SOMME(B5 B900) au lieu de =SOMME(B5:B900).

    Autre exemple, on additionne deux plages distinctes avec la fonction SOMME, en oubliant le point virgule entre les deux références de plage :
    =SOMME(B5:B900 D5:D900) au lieu de =SOMME(B5:B900;D5:D900).

    7. #N/A!

    Cette erreur intervient lorsque vous utilisez des fonctions de recherche telles que RECHERCHEV/RECHERCHEH, INDEX+EQUIV, etc... pour trouver une valeur dans une plage, mais que la valeur recherchée n'existe pas dans la plage spécifiée.

    Vous pouvez gérer cette erreur avec la fonction ISNA, qui renvoie VRAI si le résultat du calcul renvoie l'erreur #N/A!.

    A noter que RECHERCHEX permet facilement de gérer l'absence de la valeur cherchée, puisque sa synthaxe comporte un paramètre à indiquer dans ce cas : =RECHERCHEX(valeur_cherchée, tableau_recherche, tableau_renvoyé, [si_non_trouvé]).

    3. ###########

    Cette erreur intervient si le nombre à afficher dans la cellule dépasse la largeur de la colonne.

    Pour corriger le problème, il suffit d'agrandir la largeur de la colonne.

    3. #PROPAGATION! (anciennement #EPARS!)

    Cette erreur se produit en présence d'une fonction matricelle dynamique. Ce type de fonction renvoie son résultat dans une ou plusieurs cellule, par exemple : UNIQUE, FILTRE, SEQUENCE, etc...

    Si le résultat de la focntion doit s'afficher dans une plage de cellule qui n'est pas totalement vide, l'erreur #PROPAGATION! apparaît.

    Dans l'exemple suivant, la fonction unique doit renvoyer un résultat qui se propage dans la plage G2:G17. Mais la cellule G4 contient une valeur qui empêche cette propagation et déclenche l'erreur :

    Excel : erreur #PROPAGATION! (anciennement #EPARS!)

    Pour corriger le problème, il suffit de laisser la place à la fonction dynamique pour afficher son résultat, en déplaçant les valeurs présentes dans la plage de propagation.

    Planète Excel

    Exploitez tout le potentiel d'Excel : cours gratuits, trucs et astuces pour maîtriser les feuilles de calculs.

    Suivez-nous sur les réseaux sociaux :

    Excel : buy me a coffee<br />
Vous aimez notre contenu ? Offrez-nous un café !
    Utiliser les fonctions Texte avec Excel

    Utiliser les fonctions Texte avec Excel

    Si vous êtes un utilisateur régulier du célèbre tableur de Microsoft, vous savez probablement déjà à quel point il peut être utile pour organiser, analyser et présenter des données chiffrées. Mais saviez-vous qu'Excel regorge également de fonctions puissantes pour...

    lire plus
    Calendrier 2024 à imprimer PDF et Excel

    Calendrier 2024 à imprimer PDF et Excel

    Retrouvez le calendrier de l'année 2024 et ses déclinaisons au semestre ou au mois. Il vous accompagnera dans vos suivis de projets, dans l'organisation de votre travail ou tout simplement pour établir votre planning personnel. Nos calendriers sont gratuits et libres...

    lire plus
    Utiliser Excel gratuitement

    Utiliser Excel gratuitement

    Tout le monde n’a pas la possibilité d’acheter Excel ou Office, ou encore de s’abonner à Microsoft 365. C’est bien dommage, car la suite logicielle éditée par Microsoft est très complète. Excel est, à notre avis, le tableur le plus efficace du marché, et comporte des...

    lire plus
    Travailler avec les dates dans Excel

    Travailler avec les dates dans Excel

    Pas toujours facile de travailler avec les dates dans Excel... Comment changer le format des dates et heures ?  Comment effectuer des calculs simples, comme la différence entre deux dates, connaître le nombre de jours ouvrés, trouver le premier jour ou le dernier jour...

    lire plus
    Planète Excel

    Inscrivez-vous à la Newsletter Planète Excel ! 😊

     

    Inscrivez-vous pour recevoir les dernières actualités et les meilleurs trucs et astuces de Planète Excel par email.

    🎁

    Recevez en cadeau la liste complète des fonctions Excel, au format xlsx et pdf !

    Votre inscription a réussi ! Un mail vous est envoyé dans la minute pour vous permettre de télécharger la liste complète des fonctions Excel.