Sélectionner une page
Accueil 5 Cours 5 SOMME.SI et SOMME.SI.ENS : additionner selon un critère

SOMME.SI et SOMME.SI.ENS : additionner selon un critère

SOMME.SI

Tout le monde connait la fonction SOMME d'Excel. Elle permet d'additionner toutes les valeurs d'une plage de cellule. Mais comment faire lorsqu'on souhaite additionner certaines cellules, en fonction de critères spécifiques ? C'est l'objet des fonctions SOMME.SI (utilisée avec un critère seulement) et SOMME.SI.ENS (utilisée avec plusieurs critères) !

SOMME.SI

La fonction SOMME.SI permet de calculer la somme des valeurs d’une plage qui répondent à un critère. Vous ne souhaitez additionner que les nombres supérieurs à 5000 ? Ou seulement le montant des ventes de Jean ?... Utilisez SOMME.SI !

Cette fonction d'Excel est très utile pour les tableaux volumineux où vous devez filtrer les données pour obtenir des résultats précis. Par exemple, si vous avez une colonne de nombre et une colonne de noms, vous pouvez utiliser la fonction SOMME.SI pour additionner tous les nombres associés à un nom spécifique.

Syntaxe et arguments

La syntaxe de la fonction SOMME.SI est la suivante :

=SOMME.SI(plage;critère;[somme_plage]).

Les arguments sont les suivants :

  • plage (obligatoire) : plage de cellules à calculer en fonction du critère. Les cellules de chaque plage doivent être des nombres ou des noms, des matrices ou des références contenant des nombres. Les valeurs vides ou textuelles ne sont pas prises en compte. La plage sélectionnée peut contenir des dates au format Excel standard.
  • critère (obligatoire) : critère, exprimé sous forme de nombre, d’expression, de référence de cellule, de texte ou de fonction qui définit les cellules à ajouter.
    Des caractères génériques peuvent être inclus : un point d’interrogation (?) pour correspondre à n’importe quel caractère, un astérisque (*) pour correspondre à n’importe quelle séquence de caractères.
    Par exemple, les critères peuvent être exprimés sous la forme 32, ">32", B5, "3?", "pomme" ou même une fonction, comme AUJOURDHUI(). Tous les critères textuels et tous les critères qui contiennent des symboles mathématiques ou logiques doivent être placés entre guillemets (“”).
  • somme_plage (facultatif) : plage de cellules à additionner, si vous voulez ajouter d’autres cellules que celles qui sont spécifiées dans l’argument plage. Si l’argument somme_plage est omis, Excel ajoute les cellules spécifiées dans l’argument plage (les cellules auxquelles s’applique le critère). Attention : somme_plage doit avoir la même taille et la même forme que la plage.

Exemples

Voici quelques exemples pour vous aider à comprendre comment utiliser la fonction SOMME.SI :

=SOMME.SI(A2:A17;"Elena ;C2:C17) : cette formule calcule la somme des valeurs de la plage C2:C17, dans laquelle les cellules correspondantes de la plage A2:A17 contiennent le prénom Elena.

Excel : somme.si - égal à

=SOMME.SI(C2:C17;">1000 ;C2:C17) ou son équivalent simplifié =SOMME.SI(C2:C17;">1000") : cette formule calcule la somme des valeurs supérieures à 1000 dans la plage C2:C17.

Excel : somme.si - supérieur à

=SOMME.SI(B2:B17;"<> ;C2:C17) : cette formule calcule la somme des valeurs de la plage C2:C17 pour lesquelles les cellules correspondantes de la plage B2:B17 contiennent une valeur (l"expression "<>" veut dire différent de vide).

Excel : somme.si - différent de

SOMME.SI et les dates

Si vous souhaitez travailler avec une plage de dates, mettez l'opérateur de comparaison entre guillemets, suivi du signe & et de la fonction DATE. Par exemple :

  • ">=" & DATE(2024;07;01) signifie supérieur ou égal au 01/07/2024
  • "<" & DATE(2025;01;01) signifie inférieur au 01/01/2025
  • "<>" & DATE(2025;01;01) signifie différent du 01/01/2025
Excel : somme.si - date en dur

Votre critère peut également faire référence au contenu d'une cellule. Dans l'exemple suivant, on utilise l'expression ">=" & E2 pour additionner les montants de la colonne C quand la date de la colonne B est supérieure ou égale à la valeur contenue dans la cellule E2 :

Excel : somme.si - date dans une cellule

SOMME.SI.ENS

La fonction SOMME.SI.ENS permet de calculer la somme des valeurs d’une plage qui répondent à plusieurs critères simultanément. Par exemple, si vous avez une colonne de chiffres, une colonne de noms et une colonne de dates, vous pouvez utiliser la fonction SOMME.SI.ENS pour additionner tous les chiffres associés à un nom spécifique et à une date spécifique.

Syntaxe et arguments

La syntaxe de la fonction SOMME.SI.ENS est la suivante :

=SOMME.SI.ENS(plage_somme;plage_critères1;critères1;plage_critères2;critères2;...)

Les arguments sont les suivants :

  • plage_somme (obligatoire) : plage de cellules à additionner.
  • plage_critères1 (obligatoire) : plage de cellules à évaluer avec critères1.
  • critères1 (obligatoire) : critère qui détermine les cellules dans lesquelles plage_critères1 sera ajouté.
  • plage_critères2;critères2 (facultatif) : plages supplémentaires et leurs critères associés. Jusqu’à 127 paires plage/critères sont autorisées.

Exemples

Voici quelques exemples pour vous aider à comprendre comment utiliser la fonction SOMME.SI.ENS :

=SOMME.SI.ENS(F2:F17;B1:B17;"coton ;D2:D17;"L") : cette formule additionne le nombre de commandes d'articles dont la matière est le coton et la taille L.

Excel : somme.si.ens - egal

=SOMME.SI.ENS(F2:F17;B2;B17;"mérinos ;C2:C17;"beige ;D2:D17;"XL") : cette formule additionne le nombre de commandes d'articles dont la matière est le mérinos, de couleur beige, et de taille XL.

Excel : somme.si.ens - 3 critères

SOMME.SI.ENS et les dates

Comme pour la fonction SOMME.SI, si vous souhaitez travailler avec une plage de dates, mettez l'opérateur de comparaison entre guillemets, suivi du signe & et de la fonction DATE. Par exemple :

  • ">=" & DATE(2024;07;01) signifie supérieur ou égal au 01/07/2024
  • "<" & DATE(2025;01;01) signifie inférieur au 01/01/2025
  • "<>" & DATE(2025;01;01) signifie différent du 01/01/2025

Dans l'exemple suivant, on additionne le nombre de commandes d'articles de couleurs beige disponibles à partir du 01/04/2024 :

Excel : somme.si.ens - dates

Pour réaliser une somme sur une fourchette de dates, il suffit de fournir les deux dates comme critères. Par exemple, si on souhaite connaître le nombre d'articles commandés entre le 01/04/2024 et le 31/05/2024, la formule sera :

=SOMME.SI.ENS(F2:F17;E2;E17;">=" & DATE(2024;04;01);E2:E17;"<=" & DATE(2024;05;31))

Planète Excel

Exploitez tout le potentiel d'Excel : cours gratuits, trucs et astuces pour maîtriser les feuilles de calculs.

Suivez-nous sur les réseaux sociaux :

Excel : buy me a coffee<br />
Vous aimez notre contenu ? Offrez-nous un café !
Calendrier 2024 à imprimer PDF et Excel

Calendrier 2024 à imprimer PDF et Excel

Retrouvez le calendrier de l'année 2024 et ses déclinaisons au semestre ou au mois. Il vous accompagnera dans vos suivis de projets, dans l'organisation de votre travail ou tout simplement pour établir votre planning personnel. Nos calendriers sont gratuits et libres...

lire plus
9 erreurs Excel et leur solution

9 erreurs Excel et leur solution

Lorsqu'on crée une formule dans Excel, il est courant d'être confronté à une erreur. Celle-ci apparaît sous la forme d'un message à la place du résultat de la formule. Passons en revue les 9 erreurs de formules les plus courantes ! 1. #DIV/0 Cette erreur apparaît...

lire plus
Travailler avec les dates dans Excel

Travailler avec les dates dans Excel

Pas toujours facile de travailler avec les dates dans Excel... Comment changer le format des dates et heures ?  Comment effectuer des calculs simples, comme la différence entre deux dates, connaître le nombre de jours ouvrés, trouver le premier jour ou le dernier jour...

lire plus
Fonction RECHERCHEX

Fonction RECHERCHEX

Vous travaillez sur un tableau de données Excel et vous avez besoin de trouver une valeur spécifique ? La fonction RECHERCHEX est idéale pour cela : elle vous permet de rechercher une valeur dans un tableau et de renvoyer la valeur correspondante. Elle fait...

lire plus
Format de nombres

Format de nombres

Changer de format de nombre, c'est par exemple indiquer le nombre de décimales après la virgule que l'on souhaite voire apparaître, c'est aussi l'utilisation d'un séparateur de milliers, ou d'un pourcentage, ou encore choisir le format des dates, etc... Il existe un...

lire plus

Présentation des tableaux croisés dynamiques

Vous avez certainement entendu ce terme un peu mystérieux pour les débutants sur Excel : les tableaux croisés dynamiques (ou TCD). Pour beaucoup, le TCD paraît trop abstrait, et nombreux sont ceux qui préfèrent utiliser des tris, des filtres, et des tableaux "maison"...

lire plus
Filtrer un tableau Excel

Filtrer un tableau Excel

Filtrer les données d'un tableau excel Excel propose plusieurs méthodes pour filtrer une plage ou un tableau : Le filtre automatique et les segments affichent ou masquent des valeurs selon vos critères, en préservant les données de votre tableau. Le filtre avancé est...

lire plus

Inscrivez-vous à la Newsletter Planète Excel ! 😊

 

Inscrivez-vous pour recevoir les dernières actualités et les meilleurs trucs et astuces de Planète Excel par email.

🎁

Recevez en cadeau la liste complète des fonctions Excel, au format xlsx et pdf !

 

Votre inscription a réussi ! Un mail vous est envoyé dans la minute pour vous permettre de télécharger la liste complète des fonctions Excel.